Python3와 Ubuntu 22.04LTS


Ubuntu 22.04LTS는 Python3.10을 기본으로 합니다.
Python3.10에서는 formatter.py가 삭제되었습니다.
구버전 repo tool에서는 formatter에 의존성이 있습니다.
따라서 Ubuntu 22.04에서 굳이 예전 repo tool을 쓸일이 필요하다면, Python3.9의 /usr/lib/python3.9/formatter.py를 /usr/lib/python3.10/에 복사해주면 임시방편으로 처리가 가능합니다.
이밖에 3.9이전버전을 PPA로 package로 설치하고, 구버전으로 update-alternatives설정하여 전황하여 사용하는 방법등이 있겠습니다만.. 번거롭고, 용량 차지하고, 그냥 해당 모듈만 임의로 가져오는게 더 나아보입니다.